Compatible Devices

Not sure if Wearsafe works with your device? Check here to find out.

Apple

OS COMPATIBILITY: iOS 8.4.1 or later; watchOS 3 with iOS 10 or later

SUPPORTED:

iPhone
iPhone 4s, iPhone 5, iPhone 5c, iPhone 5s, iPhone 6, iPhone 6 Plus, iPhone 6s, iPhone 6s Plus, iPhone SE, iPhone 7, iPhone 7 Plus

Apple Watch
Apple Watch (1st generation), Apple Watch Series 1, Apple Watch Series 2

iPad
Wi-Fi + Cellular: iPad (3rd generation), iPad (4th generation), iPad mini, iPad mini 2, iPad mini 3, iPad mini 4, iPad Air, iPad Air 2, iPad Pro

WiFi Only*: iPad (3rd generation), iPad (4th generation), iPad mini, iPad mini 2, iPad mini 3, iPad mini 4, iPad Air, iPad Air 2, iPad Pro

iPod
iPod touch (5th generation), iPod touch (5th generation, Mid 2013), iPod touch (6th generation)*

Android

OS COMPATIBILITY: Android 4.4 KitKat or later; Android Wear 1.0 or later

SUPPORTED:

Phones with Bluetooth® low energy technology. Requires cellular data or Wi-Fi.
Watches running Android Wear.

PARTIALLY SUPPORTED DEVICES:
Tags are not supported with Android 5.0, 5.0.1, 5.0.2 on:

HTC One (M7)
HTC One M8
LG G3

Upgrade to 5.1 or newer to pair a Tag or use an Android Wear watch with these models.

NOT SUPPORTED
Android Wear paired to iPhone, iPad, or iPod touch

*The Wearsafe App requires an active data connection. These devices work with Wearsafe only while connected to the Internet through Wi-Fi.

We’re here to help.

If you’d rather talk to a real live person, send us an email or leave us your phone number. We’ll get back to you A.S.A.P!